Aproving generic/test

This is me again :slight_smile:

What happens

I deleted my previous branch and start over.
I passed almost every test except this and I have no idea what’s about.


I checked the documentation and the yaml templates, the files from other people and I don’t understand the problem.

This is the other error:

I don’t know what to do.

What do you understand or find about that problem

I don’t know whats the problem.

Did you try any workaround? What did you do?

I double checked the yml file and I don’t know what could be the mistake.


This is the link to my pipeline:

I need help with

Please someone help me. I’m so sad with this.


The first thing I can see is that your code file has this when it shouldn’t have.

Your code should look like this:

As for the links to external solutions, the pipeline tells you which links are down, and to remove them.



I don’t understand this error, which I wrote about it in the first post and I didn’t recieve any answer about ir.

It’s driving me crazy. I tried so many times with this file and I still no getting passed this test.

Beside this, I’ve already delete all the broken links but in the test continue failing in the same link. I researched in all the files for this kind of link and deleted already.

I don’t know what can I do. I’m so sad because I don’t understand the mistakes and I don’t know how to solve them.

Hi this is your problem


your new line character should be LF (for linux) no CRLF(windows)
click on that and change it

check the same problem here in forum Yamllint failed in test_generic - #2 by uneasy-ruler

Thank you for the answer, I think I solve that part with your info!

I tried to merge a few times more and I got the following error messages:

And this is the only test I need to solve to finally solve it!

Can you explain to me what’s about.

This is my pipeline:


check all the output