Build_solutions_python fails

What happens

Hi! I’m having a problem with the build_solution_python, this happens when I try to import “numpy” library of python and only happen with pylint, in fact when I run locally I have the same problem. In other hand other pipelines run succesfully

What do you understand or find about that problem

The error pylint show me is: " Line: 16 pylint: import-error / Unable to import ‘numpy’ ", I think is related with the packages configuration of nixos, however other pipelines don’t have problems

You make any workaround? What did you do?
Yes, I tried to solve the problem using this thread “Issue with import on CI” but this only produced more problem to me with mypy linting in the same pipeline


image of error:

image of local run:

link to the pipeline:

link to commit:

I need help with

I need to know If the problem is my fault or this is the configuration pkges in nixos

you can see this thread:

If you consider, you can open an issue an add the numpy library to the nix dependencies.

We always thanks the contributions.

After make the issue the conclusion was that numpy is not allowed, only can use stdlib