Can't pass test_others


I can’t pass the test test_others

I added the ten solutions on their respective OTHERS.lst and make sure all the links worked and remove those links that didn’t work.

So, what am I doing wrong?



Still can’t pass this test, the output is

locally sometimes it passes and sometimes I get something this

[ERROR] HTTP 000 in OTHERS.lst, url: '’ee/wechall/master/exploit/Training%20Programming%201/
[ERROR] HTTP 000 in OTHERS.lst, url: '’ee/wechall/master/exploit/Training%20PHP%20LFI/
[ERROR] HTTP 000 in OTHERS.lst, url: '’ee/wechall/master/exploit/Training%20Crypto%20-%20Caesar%20I/
[ERROR] HTTP 000 in OTHERS.lst, url: '’ster/Training/
[ERROR] HTTP 000 in OTHERS.lst, url: ''riteup/#Training-Programming-1
[ERROR] HTTP 000 in OTHERS.lst, url: ''riteup/#Training-Crypto-Caesar-I
We have found some problems :frowning:
You can replicate this by running:
services $ ./ test_others

I make sure the urls in OTHERs.lst worked using this site, I removed all non 200

Sometimes the same URL can retrieve both 000 and 200 http code according to the test:

So, what should I do? I would appreciate any help


Hi, I had a similar problem because the links did not correspond to the raw version of the file. For example for this link "’ster/Training/" I found that its raw version could be “”.

I hope this helps you. Good luck

Hi, first thing, this url that you send:

didn’t exist, probably because the ’ in the middle of the word master.

what I found about HTTP status 000:

It normally means: No valid HTTP response code (ie: Connection failed, or was aborted before any data happened).

In this case, I think that HTTP status 000 is probably because that the CI can’t resolve the URL (probably has an unexpected char like ( ', ", `, etc) or something like a '/r or other things) in that case you can try to change the special chars (if you have) to his ASCII representations with % and try to run dos2unix in the OTHERS.lst file to make sure that you haven’t any ‘/r’.

In the links that you send is probably that you have a '/r because if you see the link start with are inside 2 single quotes, but the links that you send with the problem only has 1 single quote, for that reason is probable that you have an ‘/r’ because the next quote is probably in another line.