Crossroads in local builds with policy and commit

What happens
When I run the policy test in my solution of hack, everything is fine, but when I run the commit test I get an error for the length of the message header that exceeds more than 50 characters, this header is as follows, "sol (hack): # 0 rootme, app-script-perl-command-injection (10) ", which has the exact name of the challenge as it is in the repository, which is "app-script-perl-command-injection ".

After solving the error of the commit test by changing the challenge name to “perl-command-injection”, now I get an error in the policy test, due to the structure of my solution, but I know that the structure of my Solution is fine because from the beginning I would not pass the test before solving the commit problem, I feel at a crossroads.

What do you understand or find about that problem
I think that the policy test is guided by the commit header to test my solution, but since the commit has the name of the challenge different from how it is in the repository, it does not find the folder where my solution is and presents an error of structure.

You make any workaround? What did you do?
To solve the error in the policy test I changed the commit header again, but I get the error in the commit test again for exceeding 50 characters in the header


The policy test before resolving the commit test error:

The commit test error:

The commit test after fixing it:

The policy test error after solving the commit test:

I need help with
I need to know how to resolve the commit test error without throwing an error in the policy test.

Thanks in advance

I’m changing the way to eval the structure, BTW, if you upload that challenge you must know that can’t count as unique since that challenge has OTHERS.lst

1 Like