error:RPC failed errno 10054

What happens

I am trying to git push my branch to the master branch but I am getting the error
(error: RPC failed; curl 56 OpenSSL SSL_read: Connection was reset, errno 10054)
Obs: I already sent a couple of push request in the morning but I did not have the same problem, everything was fine

What do you understand or find about that problem

I found this cold be the internet connection, or because the repository is too big, or the default buffer size of git

You make any workaround? What did you do?

I tried a couple of thing:

  • Double checked if my internet connection was ok
  • A soft reset and commit and push again
  • A hard reset, did the job again and try to push
  • Increase the buffer size (git config http.postBuffer 524288000)
  • Made a new clone of the repository, do the changes, commit and push again

(Optional) Why fails your workaround?

All the options I tried has failed


I need help with

An idea what else I can do or find what is the problem