Error when running makes (m .) (builds)

What happens

I’m following the instruction in the build section of the documentation. I have tried to run makes by typing m . . But I got this error: fatal: Could not reset index file to revision ‘HEAD’. I have also tried whit ./ but the file doesn’t exist: bash: ./ No such file or directory.

What do you understand or find about that problem

I have looked for information about this and it seems to be a problem with git. I have no clear what is the problem. I have reread the build section in the documentation, following all the steps.

Did you try any workaround? What did you do?

I have reinstalled nix and makes. But it did work.


I need help with

I need help to understand the error. Why does it happen? What could I do?

A mi me esta saliendo el mismo error aunque me respondieron lo siguiente :

When participating in a post, please use only English to comment.


Please try to use the post format correctly and attach either the pipelines/branch to check your case well. For the moment I recommend you clone the repository again, remember to be on par with the master branch, and check which version of Makes you are using.


Thanks for your answers!
I have already find a solution: I am using docker to run local integrations. It seems there was a problem with the operating system (I use ubuntu). I have used as starting point to create a new image to run to run local integrations.