Failed in /text/policy and /solutions/haxe Jobs

Hello everyone! :slight_smile:

What happens

I solved challenge 001 of codeabbey using hy language, however, I can’t get past the Job /test/policy and Job /solutions/haxe, it gave me some error messages, including “ValueError: ‘hack’ is not in list” in the policy. In the past, I was solving hacking challenges but when I started with programming challenges, I got this new fail.

What do you understand or find about that problem

First I thought the complexity was incorrect, but it’s the lowest complexity, corresponding to one. Maybe the failure at Job /solutions/haxe be for the same reason of first job failure.

Did you try any workaround? What did you do?

I searched at the forum for similar problems, but I could not find a similar one


Failure in Job /test/policy :

And Failure in Job /solutions/haxe :

Also, this is my commit:

I need help with

Finding why this error appears and what I have to change to solve that.

Hi @jurassic-nacho!
About the job solutions/haxe, you can just re-run it. Sometimes some jobs fail because of an external error, in this case, a communication error between the git client and the GitLab server.

(re-runned job result)

About the job test/policy, I’m not pretty sure about it, but it says something about the complexity before the exception is thrown, you could try uploading a level 2 challenge.
Screenshot 2022-03-10 202024


Thanks for your answer. I solved the problem with the job solutions/haxe as you said, but the problem with the policy job continues, even for 2 other challenges I did (002 and 012 in codeabbey)

here are my other 2 commits with the same problem with policy:


Please try to submit a VBD challenge first and let me know if it passes successfully.

1 Like

I got the same issue with VBD in /test/policy :pensive: , here is the commit:

The failed job at policy:

Also, I got another issue in /test/generic/pre_commit, but I think it is due to the previous issue. Here is the second one:


I will change the policies in a few moments, and if you try again, let me know if it helped.

Thanks for changing the policy, it solves my issue with the job /test/policy. But the other issue with /test/generic/pre_commit job continues (This is my commit). I read all other posts with the same issue, but in all cases, they have other “failed” cases before, however, I only have one failed case that is this:


[1069]( hook id: yamllint

[1070]( duration: 0.14s

[1071]( exit code: 1


[1073]( 1:1 warning missing document start "---" (document-start)

[1074]( 1:10 error wrong new line character: expected \n (new-lines)

I tried adding and removing a new line after the last line in the YAML file, but don’t work. Also, I compared my YAML file with another YAML file uploaded by another person on the repository recently, nevertheless, I didn’t find differences (including with spaces and new lines). I compared that in an online page:

*Left is my YAML file and right is another partner’s YAML file that Merges Request successfully in the repository

I appreciate if someone can help me again

Hi @jurassic-nacho, check this out.

1 Like

I solved that by removing the YAML and creating that again with the same content. It worked to solve this error:

[1074]( 1:10 error wrong new line character: expected \n (new-lines)

And the warning missing document start “—” there isn’t a problem with that, is just a warning. Thanks to all for helping me.

Additionally, I think the error got because I created the YAML in VSCode in windows OS, and it changed the format of the file, then I passed those files to my Linux OS, removed the YAML, and created it again. It works for me.

1 Like

Hello how are you? ::smiley:
The solution to the “—” warning is to leave a blank line at the end of the document. That makes that warning disappear, in some programs like vscode it does it automatically or in Geany it also does it automatically.

1 Like