I can't push in the training challenge

Good a doubt I am trying to raise the challenges of code and I want to make the merge request, I read the blogs that provides fluid attacks specifically the most promising is Help with Merge Request but it does not work, I follow the steps but in the end I get the following:

The steps to follow are:
Make a copy of the master branch.
Then create a branch with the user name in gitlab.
Then apply the following command git branch -u origin/master
then git add .
git commit -m “With the specifications given”
git push origin branch_name

But in the end I get to what you see in the picture.
Also the remote origin is well attached the image.

  1. Please replace the images with Code formated text to ease indexation for future trainees with the same problem.

  2. You are mixing repos here, seems you’ve tried to clone writeups repo inside training, you should use separate folders for each repo.

  3. The writeups repository access will be granted once you’ve completed your training cycles, so focus on your training hacking/programming challenges first.

The easiest way to solve this issue is to save your changes in a different folder outside the repo, delete the repositories (training and writeups), clone only training, and paste back your changes inside the repo.

Good the previous thing could not solve the problem, the steps of only working on the training repository were carried out but it did not work. Attached are the screenshots

PS C:\Users\anflo\Desktop\AUTO2\training> git branch
* anflo97
PS C:\Users\anflo\Desktop\AUTO2\training> git remote -v
origin  https://gitlab.com/autonomicmind/training.git (fetch)
origin  https://gitlab.com/autonomicmind/training.git (push)

Pushing leads to the same error

PS C:\Users\anflo\Desktop\AUTO2\training> git push origin anflo97
remote: You are not allowed to push code to this project.
fatal: unable to access 'https://gitlab.com/autonomicmind/training.git/': The requested URL returned error: 403

Additionally the git config for user and for email are fine, to discard it.
I don’t know if it’s a lack of permissions specifically for my user.

I think my user doesn’t have all the permissions.

Seems you have only reporter access and that role avoids you to push changes, I already gave you developer access, try pushing your changes again