Issue with commiting a challenge to the repo

What happens

I’m trying to commit a codeabbey challenge on Gitlab but the test pipeline keeps failing.

What do you understand or find about that problem

Yesterday I made a commit to my branch in the challenges repo, however due to a typo in the commit message and a duplicate solution for a language in the OTHERS.lst file the pipeline failed; today I fixed these issues and tried to do it again after checking the local build, however the repo now expects a challenge with a higher score and also due to the attempts and checks some of the pastebin links in the OTHERS.lst file started returning Http status 429 instead of 200.

You make any workaround? What did you do?

Last night I reverted the commit at fault since the test pipelines were not letting me fix an issue with the OTHERS.lst file separately.

(Optional) Why fails your workaround?

The repo still expects me to submit a higher score challenge despite me not being able to even merge the current challenge, not to mention the pastebin links will randomly return status 429 and cause the test pipeline to fail, I tried changing some of the links and sorted them but due to a VSCode screwup it sent an invalid link again with the current commit.


Link to current commit
Link to pipeline result

I need help with

Reverting the commit in a proper way and resetting the test policy so I can send and merge this challenge once and for all, and a preferred alternative to store raw code and avoid getting hit by status 429 would be nice

Ok first of all.

You get the error for the RAW because of this URL:

That happens because the CI search for the text ‘raw’ on the URL and that link didn’t have raw in any place.

BTW, you should add external solutions that have extensions with that the CI is able to determine the lang that you are uploading, for that reason pastebin shouldn’t be used.

Another thing that I found is that you remove this sol:
and that solution is valid and has HTTP status 200.

For the git things:

The policy can’t be reset, because the policy works with your code, but in this case, fails because you have a lot of changes committed and already have a challenge with sol(code). In this case, read GIT could help, you can read about this command git reset, that command should be useful to clean your branch and retry the upload of your challenge.

@pastel-code thanks for the feedback, I have reset my branch and I’m ready to try again. Though before doing that I also found this error

I looked and there are no extra lines on those two files, so what does this check for?

Edit: Nvm, found out it checks for an empty line at the end of each file and throws an error if it doesn’t find one.