"Issue with .lintGitMailMap"

What happens

When I run the test “m . /lintGitMailMap” in Makes, everything is okay, except for the fact that my name doesn’t appear in contributors.

What do you understand or find about that problem

  • I pulled the last version of the source code

  • I configured my global username and email correctly:

git config --global user.name "John Doe"
git config --global user.email "jdoe@gmail.com"
  • I checked that indeed was correct

  • I added to the .mailmap file my credentials in alphabetical order:
    John Doe <"jdoe@gmail.com"> John Doe <"jdoe@gmail.com">

  • Saved the file

  • I checked it out that was properly saved

  • I runned the command “ m . /lintGitMailMap” and everything went great, except for the fact that in the list of contributors, my name doesn’t appear.

Note: I found another developer that has the same error that me: Issue with lintgitmailmap

You make any workaround? What did you do?

Yes, Indeed.
I tried to change my credentials with my other name.

I started all the steps from scratch (Including clone again the repository)



Just try to execute the pipelines in the repository, should be okay.