Issue with mailmap list

What happens

Good afternoon. I am trying to upload my credentials to the .mailmap list but I am not really sure how should I do it.

What do you understand or find about that problem

Documentation sais that I should " modify the .mailmap file in the repository root with your credentials above" and then " run the test “m . /lintGitMailMap” in Makes to make sure everything is okay" but when I do that command prompt show me: error: cannot connect to socket at /nix/var/nix/daemon-socket/socket:permission denied. But I am not even sure if this the proper way to do it. I am using Ubuntu in VirtualBox.

Did you try any workaround? What did you do?

I tried doing a pull request to the master branch but I always get rejected and I also tried to modify the mailmap list in my branch and then upload it to the master but it does not work.


This happends when I use m . /lintGitMailMap" in Makes

I need help with

I would like to know how to properly upload my credentials.

Welcome to the forum,

The first thing you must take into account is to have installed nix in the correct way, that is to say, “no daemon” and after that to have installed makes, all these steps can be found in the respective documentation.

In case you have installed nix in “daemon” form you will have to find out how to remove that version. However, here are a couple of recommendations:

  • Install WSL2 on your system, and configure everything from scratch with clean installs. Microsoft offers step-by-step documentation on how to install this virtual system. Don’t forget to assign a specific ram memory.

  • Remember that the .mailmap update should go along with those challenge changes you are making, all in a single commit.