Local pre_commit test

What happens

My commits were failing the pre_commit test in gitlab, so I tried to evaluate it locally before submitting the changes, but I get an error in the build.

What do you understand or find about that problem

I understand that it is an error in the test preparation, not that the test fails.

Did you try any workaround? What did you do?

I tried the test in two different challenges and in both was the error.
I tried to do other tests locally and with no other I have had errors of this type.
In gitlab the test does run.
I have read makes documentation without understanding how to solve the problem yet.

(Optional) Why does the workaround fail?

My workaround doesn’t really tells me why this occurs.


Makes version

Nix version

Error message

It is installed in an Ubuntu 64-vit virtual machine in VMware.

I need help with

I would like to know if there is a way to solve it to do these tests more efficiently, or failing that, to know if I should learn more about Nix o Makes to solve it.

Thank for your answers or comments.


If the test works correctly in gitlab there is no problem. I will be checking more closely what happens with that test.