My pipeline build_solutions_python fails

What happens

Hi! I’m having a problem with the build_solution_python, this happens when I try to import “numpy” library of python and only happen with pylint, in fact when I run locally I have the same problem. In other hand other pipelines run succesfully

What do you understand or find about that problem

The error pylint show me is: " Line: 16 pylint: import-error / Unable to import ‘numpy’ ", I think is related with the packages configuration of nixos, however other pipelines don’t have problems

You make any workaround? What did you do?
Yes, I tried to solve the problem using this thread “Issue with import on CI” but this only produced more problem to me with mypy linting in the same pipeline


image of error:

image of local run:

link to the pipeline:

link to commit:

I need help with

I need to know If the problem is my fault or this is the configuration pkges in nixos

For post things related to challenges/immersion we create a template, you can see it in this post:

And please take a look at this too:

If you want to ask anything related to the challenges please follow the template, with that way you can give us more details and help us to understand what happens and how to solve it.

For solve your question please follow the template and I would understand better what happens, if you can share the commit with the code I can enter in details.

How the thread is non compliant with the template I proceed to close it and wait until become compliant with the template.