No compilation pipeline

What happens

I cannot pass pipeline because of compilation error in build-code.

What do you understand or find about that problem

The error says that my code has an undefined reference to “sqrt” (one of the math functions I use in the code). But using the command I put in the first line of my code, for me it works perfectly.
I mean, this error should be obtained if using : valac file.vala (and in my pc I got this error using it). But using: valac --pkg glib-2.0 -X -lm file.vala it should works, and in my pc it does.

Did you try any workaround? What did you do?

I try to compile my code in my pc but from the repository directory, it works fine. And try to do another commit, but still doesn’t working.


pipeline [#456954471] and #456979084

I need help with

Understanding what happen and how can I fix it.

1 Like

Hello dear user,

I have been working to fix this particular bug, please try submitting the challenge again to verify if the problem is fixed.

Hi, I think it is worse XD
so, I try again:

seems that there is an error with the branch “master” I don’t know.

Sometimes the server crashes, please try again. I see that the “solutions/vala” error is no longer displayed.

1 Like

The first time I tried it works but the pipeline of the MR throw a lot of errors.
So I tried again: and now the error is again in first pipeline in build-code.
pipeline #457750699

1 Like

It seems to have already worked, is that correct? if you have any questions, let me know.

1 Like