No newline at the end of file - Solution


This is going to be a little short. Since many talents within the process are having this problem when uploading their RM to GitLab, I have decided to upload a small step that you should follow to stop this error from appearing.

What you have to do is to find the configuration of your favorite IDE or the one you are currently using, change the “End of line sequence” section, and select the "LF" option. You can research what each of the options means for more information. Here is an example in Visual Studio Code:

You can also look for other solutions in this forum, remember that here you can probably find all those problems that you have in the repository.