Pascal pipeline error - libgmp

What happens

I push my solution of codeabbey 069 but I get Unsuccessful compilation in the pipeline.

What do you understand or find about that problem

The problem is about dependencies not installed. I used the library gmp (gmp - Free Pascal wiki) in my solution to handle integers of 1024-bit length because pascal native types are not sufficient for represent and perform arithmetic operations with large numbers in Fibonacci succession. Then, I suppose that this library isn’t allowed for solutions. I don’t know why, I didn’t install an additional package in my machine (other that the fpc compiler) and I could compile my solution (using gmp) without errors. I don’t know if there is a way to use this library or definitely it is not allowed.

Did you try any workaround? What did you do?

I tried to avoid gmp using. I replaced 1024-bits Integer for UInt64, Real and ValReal types and tried several ways for calculating modulo for checking divisibility (like Fmod() for Real vars, overloading mod operator for UInt64 arguments or by a function in ASM like in Multiple two UInt64 modulo - General Help - Delphi-PRAXiS [en] ) but both solutions obtained are not correct.


image of error:

image of local run:

link to the pipeline:

link to commit:
image of solution given using UInt64 and MulModASM() function:

image of solution given using ValReal:

I need help with

How to use big integers in Pascal? I don’t know if there are, in Pascal, data types of big integers and functions that performs precisely arithmetic operations with them, without importing external libraries. If it is not possible, how can I use gmp in my solution and pass the failed job?