Pipeline fails even when errors are fixed

What happens

Every time I try to push a challenge the same tests fail, even when I correct and verify what it says is failing they still fail.

What do you understand or find about that problem?

One of the tests that fails is /test/policy, and from what I understand the others may fail because my user does not have the correct policy to be able to upload my own vulnhub challenges.

Did you try any workaround? What did you do?

I tried to fix every error that came up, but some of the errors are not valid (for example the /test/generic/check_file) as the file works locally and on the victim vm. And the other errors seem to be related to the issue of the policy


This is the link to the pipeline https://gitlab.com/autonomicjump/challenges/-/pipelines/659408537

If more evidences are needed I can attach them.

I need help with

I need to know if my theory of the policy is correct or not, and if it is correct ask if you could modify it so that I can do the push without these problems continuing to occur. If not, if someone could tell me where is the error that I can’t find, I would appreciate it to be able to make the push.


The problem is not that you are not in the policies, about it, there is a specific pipeline that tells you that you are not in them. Now, you have multiple errors in the pipelines, all kinds, even gherkin, I recommend you to check them one by one in a very detailed way. The pipelines usually warn you where or why the error occurred.