Precommit error: Filename not matching

Hi everyone!

On the precommit checking I’m having trouble with the ‘filenames/match-regex’ rule and I really don’t know why, because I’m naming my file correctly: username.ext (Think so)
I’ll show you some images

Thank you!

Hi and welcome. Please change the image into verbatim text or give the CI log link.
On the other hand, it’s hard to tell if the username is right if we can’t see it.
You should also include the relevant parts of the documentation you followed to think that the username is right (own previous research).

Please use verbatim code to allow search feature to work inside forum

Hi! Thank you so much for your help.

/builds/autonomicmind/training/code/codeabbey/029/jllemus5.js: line 1, col 1, Error - Filename 'jllemus5.js' does not match the naming convention. (filenames/match-regex)

This is the message I’m getting. And this is the documentation i followed:

A bit more context, please.
Show what command you are running and the whole output.
The filename appears to be ok, though.

This is the link to the pipeline.

The steps I followed to make the push were:

  1. Save the jllemus5.js file to the folder where it’s supposed to be saved: (/training/code/codeabbey/029).

  2. Check the status and adding the modified file with:

     $ git status
     $ git add . 
  3. I Made the commit with:

     $ git commit -m "message"
  4. Then used

     $ git rebase -i HEAD~2

    and modified the message to be sent like this:

    sol(code): #0 codeabbey, 50 (5.22)
    - others: 5 in, 12 out, 17 total.
    - score: 22.61 initial, 27.83 final, 5.22 progress.
    - global-rank: 6781 initial, 6244 final, 537 progress.
    - national-rank: 127 initial, 109 final,18 progress.
    - effort: 7.1 hours during immersion, productivity 0.74 points/hour.
  5. Made the push with the command:

    git push -f origin jllemus5

The problem is definitely not the username.
Read through the entire log. There are at least three issues pointed out there. Two are easy to fix.

The other one, which is the one you’re asking about, I’m not sure, but it must have something to do with ESLint:

[eslint] eslint................................................................Failed
hookid: eslint

/builds/autonomicmind/training/code/codeabbey/029/jllemus5.js: line 1, col 1, Error - Filename 'jllemus5.js' does not match the naming convention. (filenames/match-regex)

1 problem

Run ESLint locally to see if it gives you more details.

Update: if you look closely at one of the easily fixed issues, you might find a line of your code which may have something to do with the ESLint failure.

@ashamed-dancer If this topic is solved, please mark it as such by checking the solution chart at the bottom of the post you consider that properly answers your question.
Otherwise could you please give us an update of the topic, if you have found something new of this problem or maybe you solved it by your own; if so please tell us how you fixed it and mark it as solved.

Since is a linter problem I think the solution is:

as roaring-lamport said on Precommit error: Filename not matching