Problem in /.../user_yaml/checks and /test/policy

Hello again!

What happens

I solved a VBD challenge, but when I push to the repository then the jobs /test/generic/user_yaml/checks and /test/policy failed for the same reason. It says: “Seems like your YAML file is non compliant.”, but I don’t see any error on it, even I am using the same format of the YAML file that is available in the forum, and my previous commit was accepted with the same format.

What do you understand or find about that problem

It seems to be an issue with the YAML file, but the job /test/generic/user_yaml passed successfully.

There is a similar issue posted on the forum, but it seems for another reason, because I did only one commit, and my branch is 0 commit behind master.

Did you try any workaround? What did you do?

I tried modifying my features file but didn’t work.


Failure in Job /test/generic/user_yaml/checks

And failure in Job /test/policy (both errors say the same):

Also, this is my commit:

And my branch is updated:


I need help with

Finding why this error appears and what I have to change to solve that.

Hi how are you?
The error says:
list index OUT OF RANGE
The error maybe that you are uploading the files to the wrong location.

1 Like


Check the advice above and also try to make sure that the folder name has that special dot character.

1 Like

Hey, thanks for your answer! :blush:

You were right. That special dot character gave me trouble. I decide to change the directory from “0359-fristileaks-1.3” to “0359-fristileaks-1-3” and then it works.

I didn’t realize that @variable-reaction posted the same problem recently and it has the solution.