Problem pushing the gears

What happens
I try to upload my changes from git to the repository, for this I do it with git push just after doing a git rebase, it takes time to execute the push command and when finishing 100% it generates an error, which is attached in the picture

What do you understand or find about that problem?
I understand that it may be because there was some update in the repository while loading my changes, or also that the command is not executed correctly

Did you make any solutions? What did you do?
I did the push command again in git, but it threw me the same error, I started my local repository from scratch and when I pushed the changes to the remote it threw me the problem again

I would like to know why this is happening and what I can do to solve it, since previously it did not happen

Pls check your email config with git config

If it’s ok then check which is the commit that your are trying to push using git log, share a screenshot here.

Looks like you are not pushing your own commit

What do you mean by not pushing my own commitment?

pls change to your branch an add a new screenshot so I could know if you correctly rebase your branch

As you can see there is not your commit, it should be the first on the list, maybe you are incorrectly rebasing or you didn’t even create the commit.

git rebase origin master?

Start the repository again, validate email, name and it is correct, try to push my changes again but it keeps generating error

pls back-up your changes delete and recreate your branch and commit your changes again, you will never need to use git merge, and pls run the command git config to check you email.

You could need also check the commands
git reset --hard
git reset --soft
git rebase

I’m still not sure why is this happening so pls add screenshots

I try to delete my branch, but it tells me it doesn’t exist in the remote repository

When verifying the commands

you must read the documentation of each command before using it, remove your local brach