Problem saving the commit message

What happens

I’m ready to make the first commit on my local branch but there´s a problem using the template and even writing the message manually using nano and vi editor. First of all, I used “git add .” to staged all files, then to use the template automatically I ran “git config --local commit.template templates/commit-msg-challenges.txt” and finally “git commit” wich opened the editor window with the template text but when I saved it there’s an error message “aborting commit due to text has not edited”.

I tried to save the commit message using nano editor and I choosed “format MAC” but this save the whole text including the text with the pound sign “#” and other characters.

What do you understand or find about that problem

I don’t really understand why this is happening

You make any workaround? What did you do?

Looking for similar problems on Fluid Attacks Community and I found this post Commit-msg: expected others - #13 by previous-bell but even changing git editor it doesn´t seems to work for me.


Using vi editor

Using nano editor , in this case wich option I should take after Crtl + O

I need help with

How to save the commit message correctly because the editor recognize it but it doesn’t let me save it.

I think that your problem is saving changes, to save changes you can use CTRL + X => y => ENTER

Also I can see that you have staged a file on the templates folder, you need unstaged undesirables changes to make your commit

And I’m not sure if you already modify the commit message with your own data, if you not you must!

The problem is not the editor I’m using, it’s because you must modify the message once you are in the editor and that’s it.