Problem with YAML folder, pre-commit

What happens

I have tried to comment on the solutions but these errors always appear, in the pre-commit it says that I need to change the name of my branch, in the yml file there is the error


warning missing document start “—”


and the Same error occurs in the test_policy.

What do you understand or find about that problem

I understand that in the YAML file it is necessary to have a blank line at the end, but even though I put it, when I comment the progress in the changes, the space at the end of the file is not reflected.
I don’t understand why in the pre-commit they ask me to change the name of the branch, since the name of my branch meets the requirements.

Did you try any workaround? What did you do?

I tried to edit the commit and add a space to the yml file at the end of the code, but it didn’t work, I have read many similar issues on the forum, but with none I can solve the problem, I have deleted my branch several times and remounted it with the fixes, but still getting the same errors.




I need help with
An explanation as for why this happens and how can I avoid this kind of problems

Thanks in advance.

Hello and welcome dear user,

Please, before making a post in this forum, check if your problem has any solution, I am sure you will find it as there have been several similar posts lately.