Run the test again after changes

What happens

I was trying to do a merge request when I found some error in some files. I already did the necessary adjusts but when try to run the test again, by clicking in the “Retry” button on the screen I can see the pipeline, I still having the exactly the same error.

What do you understand or find about that problem

I understand that always that I do some changes i should run the commands “git add .” + "git commit -m "
I am already doing that before click on the refresh button, but it does not seems to work.
Should I have to push (git push origin) every time i make some changes to run again the same test?

You make any workaround? What did you do?

I read the documentation and the forum but i did not find any references for that

Explain your workaround if you made one or explain why you didn’t do one.

(Optional) Why fails your workaround?




I need help with

With an explanation if everytime I do some adjust I need to push and create a new request to run all the tests or is there any other and quick way

First of all, as you think, if you do changes in your commit, you must push again your changes to the repo, however, after staged the new changes you will need to use the “amend” flag to edit your commit or delete the commit and recreate it, cause’ all the files must be together in only one MR

It’s important to study how works the commands and flags that you use since you can lose all your changes.

All the changes that gonna be evaluated for the CI will appear in you MR all that you don’t see here not will be tested

Hi mate
Thank you so much for the answer. I had to start all over again and almost work =(
The only test is pending is the test generic that I could not figure out what is going on reading the log file
I guess the problem is in the part
118 1:1 warning missing document start “—” (document-start)
but for me does not make sense, I double checked the layout and all the file that other users had uploaded and It does not start with “—”
Bellow the log. Could you please just help me with this issue? This is the only thing that is missing… eaXrtBi7lqPRt3akYKrhKPbt%2BBfHiT0xg%2FAQYlCcKaY8wEysagSSYwga8leJ %2FfEnuFfEfMnhFXlVmNnG5FUaP9GHPo6BjiX5qCTXHv85Dt13pf%2FZPD7LUkfD 5XoddnPxdeS22aP8IwEqopSWj4PhuNHptfIbQFFfrhNVvDEudjDRmGP2JQMh xNim1ccr8C2XQLIQZsWU%2BR56hb5uHRvSMi2A7ooMWFc75vCUy%2FnxX24EO9jl Q893Aw%2FAH3pOWXhclZcEilpffanY2tHyHg6aetQOPg%3D%3D&Expires=1620409902

you didn’t notice this error

Mate, sorry one last question/issue

My Gitlab username is “Rocken2k.”
The first time I was trying to commit I got the the error bellow

So, to avoid that I rename all my files and branch for “rocken2k”. With this I could pass through all the test from the commit part. But when I asked to merge, my request was deny because my username is different from my branch name.

I tried to submit once again the files renamed with “rocken2k” and now I am getting 2 types of error. The same one from before and this new one

I already delete the old branch but I do not know

  1. how to bypass the robot to accept my real username “Rocken2k”
  2. how to complete delete the first commit and upload a new one

Could you please just show me the way i should go to solve this 2 issues?
Thank you very much

  1. You can’t use “Rocken2k” as your username this is on the wiki, you will need to change the branch name and your Gitlab username

  2. You need to read about git reset command and its flags