Test-code /lintGitMailMap

What happens

I’m having problems with the .mailmap but I don’t quite understand why I get an error at this point

What do you understand or find about that problem

I do not understand very well why this error is pointed out to me, since I entered my user in mailmap.

You make any workaround? What did you do?

This error had already appeared to me today, however I thought my username had been misspelled and I uploaded it again, although on that occasion it was accepted.
Now I try again to upload the push to the repository and it fails again

You make any workaround? What did you do?

Retry to push to the repository and it worked however it failed again


Pipeline #776478012

I need help with

understand what is happening

Hi, that problem appears because in your IDLE are using that mail, but in the github youre using the anomimous 7933488-xmagor@users.noreply.gitlab.com. Change your configuration in gitlab and all its done. Regards

Oh no, sorry that is not your fault. But it doesn’t matter, now you have to add Miguel Gomez 7933488-xmagor@users.noreply.gitlab.com to the .mailmap file

1 Like

Thanks for the answer, although I would like to know how you realized the error

Hello, I still get the .mailmap error even though I insert that user

Pipeline #777115632

Edit 2:

Insert only my user and it effectively told me that I had to insert Miguel but in the previous attempt I inserted him.
So where should it be inserted?

Pipeline #776478012

I have uploaded a solution for your problem, remember that in the documentation it is specified that you can only add the email with which you commit. It would be best if you did not make commits with anonymous emails. Check the commit I just uploaded so you can learn from what happened. In addition, you can also use the local test to avoid wasting time.


Thank you very much for the answer, that means that the pepenile that git accepted me is invalid since it has an anonymous email, right?
In addition to this, how do I perform local tests, that is, is it possible for the bot to evaluate my files before trying to push?



Well I realized it wasn’t your mistake because I tried to do a commit and got the same error too so I looked at the graph.

Coincidentally, the last commit was made by the same person mentioned in the pipeline error.

And that error appears when you rebase from gitlab web while doing a merge, but you have anonymous mail configured.

There, in the last option. Regards.