Test_generic pipeline error - lizard-python

Hi, hope you can help me with this problem.

What happens

I get an error on a pipeline when trying to submit a solution

What do you understand or find about that problem

I got an error on the same pipeline before, but I fixed it, and when trying to push changes I get this error:
lizard-python…(no files to check)Skipped

  • hook id: lizard-python

We have found some problems :frowning:

You make any workaround? What did you do?

I haven’t make any workaround yet, 'cause I don’t know what is that error about.


I need help with

I don’t know why I’m getting this error or what is its meaning.

That’s not the real problem, scroll up to check what the actual problem is

Well, I deleted my branch trying to start over cause i tough the problem could be that I was getting the following message when trying to push

4 commits behind master, 3 commits behind ahead

I deleted the branch, but I still get:

pls add the link to the broken pipeline, as @wide-beast said lizard is not the problem

Also you need pull the master branch and rebase your branch to solve 4 commits behind master, 3 commits behind ahead

Thanks for the reply guys.
This is the link https://gitlab.com/autonomicjump/challenges/-/jobs/1481615134 I think is because of the whitespace, right? so, I’m trying to find them and only find one, so might be that.

About the rebase on my branch, I tried to do it by:

git rebase origin/master

But I get:

Cannot rebase: Your index contains uncommitted changes.
Please commit or stash them.

exactly as the message says to be able to rebase you need commit or stash your changes.

So I did git rebase again, and apparently it worked, cause I got the message that my branch is updated, but I still getting the 1 commits behind master, 4 commits behind ahead.

Error on the test_generic


This is the only failed that I see

I already deleted every whitespace in front of every line, but still getting it

you can search within the forum for some alternatives to solve trailing whitespaces problem

you are also trying to push 3 commits, remember you can only push one commit by MR

I got it right now! Thank you so much for your help.