Test_policy fails after commit and push

What happens

Hello, at this moment I am in the immersion stage.
I found that my pipeline “test_policy" fails.
I had previously sent the commit and push and it passed, but when I did the merge, the manager rejected it because the OTHER.lst file was missing. Missing OTHERS.lst file.
when I add the OTHERS.lst file with the 10 external links the test_policy pipeline was rejected by Valid solution not found.

What do you understand or find about that problem

I can’t understand the problem, I thought it would be related to the http status code, but I checked each link and it gives code: 200, I checked the other questions previously asked about test_policy, but no solution seems to work for me.
When I run the test_others locally, it says it passed successfully, but the test_policy, it keeps saying the same error.

You make any workaround? What did you do?

I tried making the changes and checking them locally, changing some external urls in the OTHERS.lst file, I also tried changing the commit message and tried to follow the OTHERS.lst links rules.

(Optional) Why fails your workaround?

I got the message in the test_policy pipeline : Valid solution not found. Touched files in the last commit for the user: Seems like your solution name is non compliant.

But I think the OTHERS.lst file is fine because I have checked it locally.


image of error:

image of local run:

link to the pipeline:
Link to the test_policy pipeline

link to commit:
Link to the commit

I need help with

I don’t know why the pipeline fails and I try to make workarounds but didn’t work, what I should do to fix this.

You are two commits ahead of the mater, this wants to say that you are trying push two commits in the same MR this is not allowed.

1 Like

Thanks then can i make a git rebase and drop my others commits?

that depends if you need the changes in your others commits

git reset --soft
git commit --amend

1 Like

Thank you that was the solution, it works for now.