User_yaml failed with no explicit reason

What happens

My commits are not accepted due to pipeline failure in Job /test/generic/user_yaml (script failure).

What do you understand or find about that problem

I understand that there is possibly an error in the .yml file associated with my programming solution.

You make any workaround? What did you do?

I have reviewed the numbers format in the .yml file, changing the decimal precision of the values, I have tried to add/remove the final empty line. I have reviewed the template and other files accepted for other people’s solutions.

Why fails your workaround?

The file is not accepted by the job in the pipeline, when there is an error in the file, there is a mention of it in the log file, but in this case there is no clear reason why the job fails.

I need help with

I would like to know if there is a way to get the exact reason why the job is not being completed so I can fix either the files or anything needed to get the solution built. I have not experienced these kind of problems commiting before, always I had an explicit mention of the error triggerer. The only major change I made since the last successful commit was changing my user name in the git config variables to comply with the MR requests.

Re-run the test, it should work. Sometimes the jobs fail without a reason

you are 5 commit ahead the master branch, remember just one commit per merge-request

It happened with a couple of other tests earlier, I re ran then and they worked, this one is not the case. Thank you, though

1 Like

Thanks for the reminder, I plan to fix it once this issue is resolved, as from the first commit I have been experiencing the same problem

To solve the problem, you must solve this problem, as not following the rules can lead to unexpected behavior in the pipelines as in your case

Does anybody have an idea of what the problem could be? I already resolved the number-of-commits issue and it’s still happening the same, I am stuck as I am unable to find the cause of the problem.

I’m checking your problem right now, I will let you know what the origin is

1 Like

The problem is now solved, it was caused by a small error in the pipelines code.
Please pull the changes and rebase your branch, sorry for the inconvenience, if you have any other problems, please let me know