Access denied git push

### What happens
I'm trying to push my branch to the origin as to be able to do a git pull for all of it. At first I thought it might have been a problem with my branch and using i was able to properly stage and commit my branch. As i I try to do the next step of git push origin master this pops up remote: HTTP Basic: Access denied. The provided password or token is incorrect or your account has 2FA enabled and you must use a personal access token instead of a password. See It has happened before as well, when i tried to do a git pull before on the master branch.
### What do you understand or find about that problem
I'm unsure if its that i need to create a new personal access token, as i found a tutorial explaining this process but this error doesn't ask for a password when i re enter it. Or it might be that I need a new SSH key for GitLab? The old key was from an Ubuntu VM that i had issues with and had to uninstall and download ubuntu via the microsoft store to be able to clone the repo. 

It might also be that I am substituting the wrong names in the git push origin master command. I'm super new to this whole process and am easily confused with which name is what.
### Did you try any workaround? What did you do?
I have not done a workaround yet, as I am still unsure of what's going on.

### Evidences
![Screenshot 2023-12-07 071509|690x288](upload://y9Pjbiz0vAo84w0CSgKCCaCNIFn.png)

### I need help with
I need help with figuring out how to git push origin master before i can do the git pull.

 Can you see the screenshot I posted in evidence?

The format of your post is incorrect, please do the post again with the correct format. Currently, it looks like a piece of code.

Thank you, I was unsure if the picture showed, I did edit the post hoping it would show but it seems it didn’t.

But I have solved the issue by adding a new ssh key then deleting the cloned repository and re-cloning it with said ssh key.

1 Like