I cannot push commits

What happens

I am trying to make my first push, and I have everything set up. I added the mailmap, obtained the 10 external links from OTHRES, and have the YAML and code properly approved by Codeabbey. I ran tests using “m .” and all the tests run perfectly.

My problem lies in attempting to push a commit, and I encounter the following error:

when i send: git push origin edwinjhs

What do you understand or find about that problem

I have tried everything; I even formatted my computer to check if there was any issue with the SSH keys or previous computer configurations, but nothing changed, and the error persists. After conducting research, I found suggestions that the repository administrator may have set up a configuration or restriction affecting my push attempts, possibly related to security policies or other requirements that I might not be meeting. Despite trying various solutions and looking for answers on the forum, none of the similar problems I found could resolve my issue.

I also read about the possibility of pre-receive hooks being configured in the repository, which might be disallowing my push actions.

My SSH keys are correctly connected to GitLab, and my email is consistent across all platforms.

Did you try any workaround? What did you do?

I have attempted to reset the SSH keys, change the global configuration of my terminal, created multiple keys, and uploaded all of them to GitLab. I extensively searched for documentation, watched tutorials, and even completed a quick GitLab course to ensure I am not missing any crucial steps.


I need help with

I need assistance to successfully perform my first merge to continue with my selection process.