Makes installing process goes wrong

What happens

I’m trying to install Makes’ files but it seems to have some error. Following the documentation (img 1) I installed NixOS with its command in WSL, I already had git and bash tools so I went to the next step that was installing the makes framework. The first thing I couldn´t found was the current version of that framework in the linked page (img2) so I came to this forum looking for some previous questions and versions I could use. Some people recommended v21.11 and looking around I found v24.02(that had some failing checks).
Despite following the documentation, I get the same error in my terminal (img3).

What do you understand or find about that problem

Theres some permissions I still not have in the repo or I’m not installing the correct framework’s version.

Did you try any workaround? What did you do?

I consulted lots of questions in this forum and read the documentation, I also explored some other autonomic/fluid pages looking for something helpful.



Link and linked page:

Error in terminal:

I need help with

I don’t know why the installation fails and I try to make workarounds but didn’t work, what I should do to fix this.

Here is the correct way to install nix and then makes.

Installing NixOS:

  1. sh <(curl -L --no-daemon
  2. Close terminal and reopen it.

Installing Makes:

  1. nix profile install github:fluidattacks/makes/(version) --extra-experimental-features nix-command --extra-experimental-features flakes 2.


1 Like

Hi, as I had the multi-user nixos, I decided to uninstall it in order to get the single user one. It was ok but then it didn´t work again so today I uninstalled it as the Nix documentation said so.
The thing is that now im getting this error and I can´t find any solution on its forum.

As you see, im using the correct command and im pretty sure I uninstalled it with the following commands:

-With daemon:
sudo systemctl stop nix-daemon.service
sudo systemctl disable nix-daemon.socket nix-daemon.service
sudo systemctl daemon-reload
sudo rm -rf /etc/nix /etc/profile.d/ /etc/tmpfiles.d/nix-daemon.conf /nix ~root/.nix-channels ~root/.nix-defexpr ~root/.nix-profile
for i in $(seq 1 32); do
sudo userdel nixbld$i
sudo groupdel nixbld


-Single user:
$ rm -rf /nix

Then i tried to run makes command as you said but then i get this mistake:

If you’re using WSL, please uninstall and clean all about the relational of this and try again.


I already uninstalled and deleted all the info related to nix in:

  • /etc/bash.bashrc
  • /etc/bashrc
  • /etc/profile
  • /etc/zsh/zshrc
  • /etc/zshrc