Problems running the ./ command

What happens

When I install the makes framework in the root of the repository challenges directory in my local environment, it does not identify the build.ssh file.

What do you understand or find about that problem?

I am not picking correctly version at time execute the command:
nix-env -if

Did you try any solutions? What did you do?

I tried to pick the version explicit, present in the value of atributte “makesVersion” prenset in these configuration file:

(Optional) Why does the workaround fail?

Is probably I do not pick the correct version and must search in other part of the repository


I need help with

the election correct of current version of makes framework. When I can find it? or what I can do for that file appear in the the root of the repository challenges directory in my local environment?


All that you need is to install nix and after that makes. You can check the version of makes here, finally, you just need to execute “m .” in the root of the repository.


Hi. I do runned all steps than you mentions but the problem continous.

Keep in mind that I am configuring this from a virtual machine in VirtualBox, which has the NixOS ISO image downloaded from its official site: Download Nix / NixOS | Nix & NixOS.

Additionally, I reinstalled the Nix package manager in two ways.

  1. Using the following link:
    NixOS Search
    Here, I selected the “nix-env” tab.

  2. The second option was to follow the instructions at:
    Download Nix / NixOS | Nix & NixOS
    and execute the command for a single-user installation.

After that, I ran the command to install the Makes framework version, in the root folder of my local repository named “challenges,” in two ways:

  1. nix-env -if
  2. nix-env -if

The result, as you can see in the attached screenshot, does not lead to a successful compilation using ./ or m.

Try to install with this way:

nix profile install github:fluidattacks/makes/23.06 --extra-experimental-features nix-command --extra-experimental-features flakes


1 Like

Hi. Good Afternoon. I executed the command “nix profile install github:fluidattacks/makes/23.06 --extra-experimental-features nix-command --extra-experimental-features flakes” in the root folder of local repository of challenges, and getted as result, in the terminal, the attached information in the screenshot “resultado comando nix profile install”. I did not write any command, I only waited some seconds and next the terminal changed its content for the content the appear in the screenshot “Screenshot please type the command you want to execute” and this last image is the current content of my terminal. what will must do I how next step?

Hi. Are you there? Maybe you can guide me on the last question I shared with you.

Hello sibarguen, I’m here! I noticed you already have Makes installed. Below is a list of the current tests the app runs in automation. Feel free to run any of these tests and explore the responses. Best of luck!

OK. Thanks for that information. I want to ask you a last question. Then now does not necessary run the command “./” in the root folder of challenges repository? Because still appears the error “bash: ./ No such file or directory” when I execute “./” in the root folder of challenges repository. You can see it, in the screenshot that I attached in these answer. The command Is very important to work with the repository or I should not worry about it now that “m .” runs great?
No such file or directory

You just need this command in this case:

$ m .


1 Like