Negative effort expected by /user_yaml/checks job

What happens

Pipeline failed on /test/generic/user_yaml/checks job when I pushed a new commit.

What do you understand or find about that problem

/test/generic/user_yaml/checks job finishes with error status. It says that effort on my commited .yml file is bad calculated (expected effort must be a negative value!), but this is weird and doesn’t correspond with the actual .yml registered value (is the same effort expected, but in positive). Also, current effort marked by job result doesn’t correspond with the .yml registered value:

Did you try any workaround? What did you do?

Yes. I tried to calculate the total time and effort again, then I modified the .yml file and commited again, but error persists (a negative effort value is expected and current effort value -marked by job result- doesn’t correspond). Also I tried to re-run the failed job with the same result:

And I tried to run the job test on local, and same result again:

(Optional) Why does the workaround fail?

I don’t really know. It’s the very first time that occurs to me after a lot of sucessful previous commits, and it’s really weird, because the negative expected effort value (it doesn’t have any sense).


Evidences was attached before :point_up_2: :point_up_2:

I need help with

Try to find the error related causes and know if it’s my mistake or it’s something related with pipeline automatic tests. Thanks for any help in advance!

Hello, this usually happens when the total-time has an incorrect value, please check this, try to add a little more time in the Time Doctor and recalculate the effort.

Thanks for your advice, but I figured out the solution, and it was always my mistake :see_no_evil:: error was related with a bad date (I was using yesterday’s date instead of update it) :sweat_smile:

Now it’s working:

You can close this thread, please… and sorry again!