Push Error in Commit

I’m trying to push my solution but I get this error. Can you help me out?

I have a new email and I set this with git config --global user.email "nd.sanchezq@gmail.com"
I also deleted my Windows Credentials, Uninstalled Git, but it doesn´t work
any suggestion?


Make sure to also update your commit email on your account’s Gitlab settings.

Hi there @handy-merger

Try the suggestion of @infinite-loop , if that doesn’t work it could be several things:
First, make sure you have the permissions to do the pull and push to the repo, if you don’t then you can request for them on https://fluidattacks.com/forms/access.
On the other hand, I would check with git config --list if the username and email are set as is indicated on https://gitlab.com/fluidattacks/writeups/-/wiki_pages/Submission (first item on General Criteria).
The last thing that comes to my mind is that I had a similar issue when I cloned the repo with other user/email configured, after the clone I changed to the right ones but… even after that git didn’t let me do the push.
So… my solution was to copy my files somewhere save, delete the repo, configure the right username/email, re-clone the repo and finally re-add the changes.

If you used another method to solve it, please tell us or if this topic is solved, please mark it as such by checking the solution chart at the bottom of the post you consider that properly answers your question (go to the answer, click on the ellipsis and then the solved button).