Submitted a solution that doesn't match my policy

What happens

I was granted access to the repository last Thursday 6/22 and I started solving a problem in Fortran that same day, because when I looked at the policies file I saw that the available languages for the “technical-challenges” item had that language assigned. I thought that was the policy I was assigned to because in the email I received from my recruiter it said “Welcome to Technical Challenges”. So I compiled all my files and made a commit last Saturday 6/24 to my branch, but the pipeline didn’t succeed. After reading the logs I knew that I was assigned to a coding policy last Friday 6/23. So, I think that’s the main reason why the pipeline failed. I started solving a different problem in one of the languages assigned to my real policy and I’m ready to make a commit, however I’m not sure how should I proceed.

What do you understand or find about that problem

As I said, I think the pipeline failed, because I solved a problem in a language that was not assigned to my policy.

Did you try any workaround? What did you do?

I think I could remove my Fortran files and add the new files of my new solution in the language I was assigned to. However, I’m not sure if I should do that in a new commit, or should I do a commit --amend. I’m in doubt because the guide says each solution must have only one commit associated. Another thing I think I could try is just to reset my branch and start all over again by adding my new files. The other option I’m thinking of is just to make a new commit for my new solution and leave my Fortran solution files as they are. However, I’m not sure if I would be able to complete my MR in that case due to my first commit pipeline having failed.

(Optional) Why does the workaround fail?



This was my last commit -amend for my Fortran solution:

chall\sol(code): #0 codeabbey, 102 (11.37) (5ae5a6d5) · Commits · Autonomic Jump / challenges · GitLab

This was the commit in which my username was added to the policy file last Friday 6/23:

makes\refac(build): #414.292 modify policy (ed865ff5) · Commits · Autonomic Jump / challenges · GitLab

I need help with

Please let me know how should I proceed in this case so that I can upload my new solution and be able to complete my MR.

Thanks in advance.

Welcome to the forum,

Remember that the correct step-by-step would be:

  1. Upload your branch updated with the latest commit of the master branch.

  2. Make sure that the branch pipelines are running successfully.

  3. Send the merge request and wait for feedback. In case you need to change something, remove your remote branch from the repo and start over.

If you made a mistake by uploading the code in another language, try to upload that challenge by passing it to the correct language of your policy.

Actually, you have several errors, I would recommend you start reading the failed pipelines to get an idea. Remember that the use of cycles is forbidden.


Thank you for your response. I will go with that one: re-writing the Fortran program to the other programming language. When it comes to the cycles you mention, the logs don’t say anything about that, but still I will take a look, since it’s specified in the specific criteria section.

Hello @imaginative-watch, I just uploaded my commit with the program in the new programming language that matches my policy, but I’m having a few issues:

  1. The job /test/policy (#4544914885) · Jobs · Autonomic Jump / challenges · GitLab is failing because the complexity of my problem is greater than the maximum allowed for my policy. I used a complexity that was allowed in the policy I thought I was assigned to (“technical-challenges”). What should I do in this case?

It was solved by just manually changing the complexity of the problem in the commit message and the YAML file accordingly.

  1. The job /test/others/code_sort_by_ext (#4544914883) · Jobs · Autonomic Jump / challenges · GitLab is failing. It says the URLs are not sorted correctly, however I’m seeing that they are indeed ordered alphabetically. I’m adding the one with extension “.R” at the top, just like it’s suggested in the logs.

I was missing the correct ordering in the other OTHERS.lst file that I modified when adding external solutions for other problems different from mine. In particular, files with “.R” extension need to be added to the top always, just as it says in the logs.

  1. The job /formatYaml (#4544914841) · Jobs · Autonomic Jump / challenges · GitLab is failing but I’m not sure what might be the reason. The logs don’t specify something in particular. Please help me understanding what might be wrong with my YAML file.

My YAML was missing an empty new line at the end of the file. This line is added automatically when you run prettier (even online versions of it), but you can add it manually too.

I’m looking forward to your comments about these issues, so that I can continue with the process and send my MR.

Thanks in advance!