/test/generic/pre_commit job error

What happens

I have been trying to make a commit, but i can’t because the /test/generic/pre_commit job fails.

What do you understand or find about that problem

I read other threads with the same problem and some posible solutions, but none of them worked for me.

Did you try any workaround? What did you do?

I tried:

  • Adding “—” at the first line of user.yml file.
  • Checking the new line character (to ensure that is LF).
  • Using “Trim trailing whitespace” option in VScode.


Pipeline output.

New line character format.

pipeline: https://gitlab.com/autonomicjump/challenges/-/jobs/2847751151
commit: https://gitlab.com/autonomicjump/challenges/-/commit/c3b832d0cc6f2c9c2132a51302d99b171393f012/pipelines

I need help with

I need to pass this job, this is the only that is failing, thanks.

If you check the error you can notice that the one that is failing is the trailing whitespace. Check your .feature file for lines with whitespace and fix it. There are some visual studio extensions that help you with that.

1 Like