Issue pre_commit check

What happens

My pipeline just has this message. But I don’t see any error on the file.

What do you understand or find about that problem

It seams that the yml file structure has change? I didn’t have this issue with my first challenge.

Did you try any workaround? What did you do?

I tried to add an empty line just has here says so:


1 Like

Welcome, dear user,

As you can see, you have whitespace in your code file. That which is currently highlighted in red.
Captura de pantalla de 2022-01-25 10-10-00

The second problem is in your .yml file, please check carefully, something should be left…

:smiling_face_with_tear: I had been reading this file for hours I don’t see any difference with other accepted files


You have two white lines instead of one.
Captura de pantalla de 2022-01-25 10-10-35

strange it has just one on my PC on the linux machine and on windows

I just run another three pipelines one with the extra line and another without any extraline and also copied a working YML from someone else just changing it to my data, nothing works :sob: :sob: :sob:

all pipelines have the same error

any idea??? :upside_down_face:

Please check this post: Fix End of Files error - #5 by definite-territory

sorry to bother you again, but that didn’t work. I tried adding the extra lines to all the files as the topic says, created new files with a different text editor, and put the code here so it doesn’t have any extra space. But nothing works, The same error persist. Pipeline:

hi, have you try to leave a space at the end of the yml file? I can see in the last pipeline you haven’t
for the white spaces I use an extension of VS, that someone here in the forum recommended in one topic.

@lethal-snore Yes. the thing is that with some text editors It show one extra line and with other two, a had try several combinations(different text editor and different number of extra lines.
Example the exact same file on VScode and on Ubuntu text editor:

I’m thinking that the error is not on the YML but on the .vala. But I don’t see how I get this error there is no trailing-whitespace on my Code.

and maybe the .yml thing is just a warning because it says passed

@lethal-snore Which Extension???

I am runing out of ideas :smiling_face_with_tear:

The extension I have is trailing whitespaces highlighter in VScode. However, you could look for it in the forum answers. It is the answer for a question about de "start “—” " issue.

The extension didn’t work. But I finally fixed it. I found this setting on VS. I opened and saved again all the files using VS (with an empty line at the end of each file)