Trouble with the tests

What happens

I’m having some troubles at the time to push my branch and some of the pipelines do not pass

What do you understand or find about that problem

There are some pipelines that I’m having troubles, I fixed some of them, but do not have clarity with some of them

Did you try any workaround? What did you do?

I tried making some changes, but there are some that I do not understand well


This is the response of the gitlab panel

But this is the response when I run it locally, it says that file do not exists

But here is the file inside of the folder

I need help with

To understand which is the problem and how solve it to pass the tests

Thank you


Remember that you must add 5 hours to the commit date and also the whole solution must be sent in a single commit.

I going to fix the other problems and finally add the 5 hours, thank you

I made that, but now I’m having a trouble because I had to merge the branch and there are 3 commits, how can I solve it?

I’m having some problems, because there are some pipelines that pass when i run it locally, but when a push it to Gitlab it says that is wrong, is there a reason because it fails in Gitlab and not locally?

Thank you

You need to understand that all changes must be submitted in a single commit. Read more about git commands or something like this.

They need your solution (and all the other requirements) in one commit to pass all the jobs/actions/tests. Once you made just one commit, then it’s probably to your submission pass most of the tests.

I solved (almost) all the problems and pass the pipelines, but there only one left that is failing, the next test

I do not understand very well which is the problem with the compute of the ranking