Commit and pre commit error

What happens
When making the changes in the repository and waiting for the pipes to run, I get don errors that are shown in the images:



I check the body of my commit in git:


What do you understand or find about the problem?
I understand that my commit is not done properly, but I do not understand how it should be, since I am based on the other challenges that are in the repository and also on the documentation.

Did you make any solutions? What did you do?
I tried looking for information in the forum to see what my problem is, then I made my changes again, but the problem still occurs.

The commit msg is explained here Hack and Code | Autonomic Jump, we’re not longer supporting the template you are using, be careful with capital letters

were you able to solve the problem?
I have the same problem.

Please add the link to your pipeline so we can review it.

I can’t upload it, the page has a 404.
I am waiting for him to recover.

You need to push your branch to the repository as it no longer exists

Most of your problems are produced because you have a lot of commits in the same branch

you need add all the necessary files for your solution in only one commit and also you need to rebase your branch

check how the following commands works

git rebase
git reset --soft
git reset --hard


that number should be, at best, something like 0|1

Okay, thank you so much.
I already did, let’s see if it improves.
thanks so much.

Hi all, I have the same problem. I’ve tried to solve it with your comments but it doesn’t work, I’m using the correct commit message according to the Commit | Autonomic Jump documentation and following previous commits but it doesn’t work. I keep getting error in the pipeline (pre_commit) and I have no idea how to fix it.

This is my commit according to documentation.

This is the error message I get. I have no idea how to fix it or what file to modify to fix it.


Please refer to the documentation and read the pipeline error.