Error lintGitCommitMsg

What happens

I don’t understand why this error is happening. I really see that the commit msg is fine.

What do you understand or find about that problem

I don’t really known a reason why this is happening

Did you try any workaround? What did you do?

I copied the exact template from the docs and replace it with my information but did not work


I need help with

I need help solving this issue

Have you tried to restart that job? sometimes the jobs have problems and need to be restarted. if that doesn’t work, idk what could be happening

I have just try that but it still don’t working :c

You must carefully read the docs Commit | Autonomic Jump as you can see your commit message is incorrect


if this is not your commit message maybe you are pushing an incorrect commit

I really don’t see the problem.

This is the template I am following:

The only thing I see is the whitespaces but when I do the commit I put them so really do not known what can be.

Hi, everyone. I have the same problem here. I debugged all the errors from my 5 or 6 attempts trying to pass my first commit but this is the only pipeline (lintGitCommitMsg) that I don’t have idea how to solve.

This is the error msg that I get. I have no idea how to change or see the header, or add the scope, subject and type for the input file mentioned.

If one of the moderators can help me with this issue I’d really appreaciate it.

────────── Running ──────────
[INFO] Linting f53562d24
[INFO] Linting 26f7e0190
[INFO] Linting 178ba2cf0
[INFO] Linting ba6594f03
[INFO] Linting 1467ad0fd
[INFO] Linting 70cd8ab4e
[INFO] Linting 188289ae2
[INFO] Linting b9f4ac700
[INFO] Linting 0da6a514d
⧗   input: Update code/codeabbey/001/gusecheverry.f90
✖   header must be lower-case [header-case]
✖   scope may not be empty [scope-empty]
✖   subject may not be empty [subject-empty]
✖   type may not be empty [type-empty]
✖   found 4 problems, 0 warnings

Hi all, I have the same problem. I have tried to solve it with your comments, I have restarted the job, I am using the correct commit message according to the documentation Commit | Autonomic Jump and following previous commits but it doesn’t work. I keep getting error in the pipeline (lintGitCommitMsg) and I have no idea how to fix it.
This is the error message I get. I have no idea how to fix it or what file to modify to fix it.

If someone can help me I would appreciate it.

Hi, good evening!
For what I see, the commit msg isn’t well formed. In your case is this:

chall\sol(code): #0 codeabbey, 01 (1.0)

But this is the correct one:

chall\sol(code): #0 codeabbey, 001 (1.0)

That additional 0 has to fix your problem. Anyway, if not, just let me know.


Good afternoon.
Thank you very much for your help, I did the commit like this but it didn’t work:

The pipeline continues to error.
Thank you so much!

Hi, futile-portfolio.

Delete your branch from the repository in GitLab, proceed to download the repository again, create your branch and upload the solution to your challenge along with the 10 external links. Remember that only one commit per challenge is allowed.

Also remember, before upload your solution, to change your GitLab username as it appears in /policies. And the name of the author of the commit must be composed of firstname, space and lastname. No accents or special characters.

1 Like