Pre_commit missing document start "---"

What happens

Already passed al test but having issues with pre_commit test receiving the following error:

1:1 warning missing document start “—” (document-start)

What do you understand or find about that problem

I can see many questions about this issue but none of the solutions work for me, like adding an empty line at the end of the file.

You make any workaround? What did you do?

Currently I’m running on Parrot OS 5.0, with vim version NVIM v0.4.4 and GNU nano version 5.4, I added an empty line at the end of the .yml file and got the same error, also tried with also adding a blank space both with nano and vim and still not working, I was able to read some posts that it was solved with using VS and some options, but my current environment doesn’t have it and it should work with vanilla linux en either case as git version 2.30.2 should work fine.

Why fails your workaround?

I’m guessing it has something to do with the char codification of the document and maybe changing the UTF encoder should fix it but not sure if there is another solution or if it’s a problem with gitlab



I need help with

Any advise about how to pass this job

1 Like

Hi, you could try to solve this problem using Visual Studio from the browser at:

Hi, I’ve just tried from, did this: Created a new file, Copied my yml from my local machine, Pasted in the website, added manually a blank like at the end, saved the file, copied in my git folder, and made the commit from zsh console, got the same result:

I think everything else is ok, please advise

The main error in the pipeline is not the one you mention, if you check a little further up, you will be able to see

Oh really, thank you so much! You can close this now, my apologies for that one