Error : lintGitMailMap

What happens

I understand that the repository is telling me that I have not modified my .mailmap file.

What do you understand or find about that problem

I tried to search the forum and although I did find similar problems I did not find a concrete solution

You make any workaround? What did you do?

I re-read the documentation to see if I was missing any steps, but as far as I understand I followed the steps correctly.


Pipeline #748799560

I need help with

Understand the reason for the error

Hello friend, what you should do is to replace your gitlab username to your personal name, let’s say instead of configuring as follows:

git config --global "muelasvill"

you do it this way:

git config --global "John Doe"

note the blank space, it is mandatory.

in addition to that you must also verify that your data appears in the .mailmap file.
they are sorted alphabetically, if you don’t find it you must add it this way:

John Doe <> John Doe <>

This error is related to a new implementation in the documentation, please refer to this post.

Thank you very much, it worked for me :3