Issues with .mailmap file

What happens

Even though my credentials are in the .mailmap file, I can’t finish the build process succesfully.

What do you understand or find about that problem

At first I thought that was the git confugration but it is ok. Then I looked at the .mailmap file in the repository but it is ok too.
Maybe the reason is because the first commit that I did was with git config --global = edy89.

Did you try any workaround? What did you do?

I have tried a lot of things but nothing has solved my problem:

  • I recloned the repository
  • I deleted the credentials from the .mailmap file pushing, adding credentials and pushing again
  • I changed my credentials to edy89 <> edy89 <>
  • Checking the .mailmap config with commands like: git shortlog -se git check-mailmap 'Edison Colorado <>'

Why does the workaround fail?

I could note that the first commit that I did, was with the git config --global = edy89:

but even when I realized and changed my git configuration, the problem never was solved and when I run the build process, it is always asking me "Please add a .mailmap entry for: edy89 <> even knowing that my git config for is Edison Colorado <> Edison Colorado <> now…


Screenshot 2023-07-07 at 7.21.58 PM

specific job:

I need help with

I need help getting the repository to recognize my .mailmap configuration as Edison Colorado <> Edison Colorado <> and can finally finish the /lintGitMailMap job task succesfully, it is the last thing to make a MR :pray:


In case you have made the previous commit with other data, you must add again in this commit in the .mailmap the current data.


Hello again and thanks for answer… That’s the problem! I already did:
this is the last commit where I put the correct format into the .mailmap file but it still failing, what else can I do?

I was referring to if you were approved for a Mergue request but I see that you were not, before committing make sure that your data is correct. What you could do is clone the repository again.

I re-cloned the repository, checked the .mailmap file if my user configuration was there and then I ask for a MR but it failed for the same reason I guess… :pensive:


*There is another way to re-start whole process? (e.g create another branch)

Please consider doing the steps correctly:

  1. you upload your branch, and if all goes well.

  2. Make the merge request.

Remember that as it is your first commit, in case the .mailmap asks you to add in a specific way your user, you must do it. Don’t forget to run the test locally to save time. I also see that you are mistitling the commit.