Review merge pipeline error

What happens

An error is ocurring due to more than one commit, being in place when trying to merge.

What do you understand or find about that problem

More than one commit is being done, and this cant happen

Did you try any workaround? What did you do?

Ive tried doing everything in one commit, but then it fails the pipeline for the requested files. Also tried selecting the option of squashing the commits when creating the merge.

(Optional) Why does the workaround fail?

Because it adds files that I am not supposed to create or are in my intended policy


I need help with

A hint or indication on what to do. I am having two commits at the moment, because one (the first one) is a merge where I perform this in order to get my branch up to date with master branch. Due to it being 114 commits behind.

And the second commit is when uploading my solution.
Im pretty sure the first commit that is done to update my branch should not be there. But if I dont perform it, which I already tried. And try to upload the solution I get some errors as well (but on the commit side). This way im able to pass all pipelines on commit side, but fail on the @review merge pipeline.

Probably the answer to my question would be, you can only have one commit per merge as the documentation says. But then my question would be, how could I update my branch so it does not appear that it is “n commits behind master”, without performing a commit or only performing one commit including my solution to the challenge.

You need to improve your knowledge of git. Also, remember that your branch should pass all the pipelines before sending the merge request.